Database upgrade is complete and all Flow XO services are operational. Thank you for your patience.
Posted Jun 07, 2026 - 00:19 UTC
Verifying
Database upgrade is complete. We are bringing production servers back online and monitoring for stability. Services may be intermittently available while we verify everything is healthy.
Posted Jun 07, 2026 - 00:18 UTC
In progress
Scheduled database upgrade is now in progress. Flow XO services are offline while we upgrade the production database. We will post updates as work progresses.
Posted Jun 06, 2026 - 23:55 UTC
Scheduled
We will be performing a scheduled database upgrade to improve platform performance and reliability. Flow XO services will be unavailable for the duration of this maintenance window (approximately 2 hours). We will post updates here as work progresses and when services are restored. We apologize for any inconvenience.
Posted Jun 06, 2026 - 23:07 UTC
This scheduled maintenance affected: Application, Messaging Servers, Web Chat Servers, Slack Servers, and Facebook Messenger.