WhatsApp, Instagram, Messenger are Down

Incident Report for Flow XO

Resolved

Meta platform services have recovered and messaging is operating normally. This incident is now resolved.
Posted Jun 12, 2026 - 17:00 UTC

Monitoring

Meta platform errors have subsided. We are monitoring for 15 minutes to confirm services remain stable before closing this incident.
Posted Jun 12, 2026 - 16:45 UTC

Update

Update from Meta (WhatsApp Business Platform — WhatsApp Business Account Management):

We are currently experiencing high disruptions impacting WhatsApp Business Account Management. Our engineering teams are investigating the issue. We will provide another update within 1 hour or sooner if additional information is available.

Meta status: High disruptions
Source: https://metastatus.com/whatsapp-business-api
Posted Jun 12, 2026 - 16:18 UTC

Update

Update from Meta (WhatsApp Business Platform — Embedded Signup):

We are currently experiencing high disruptions impacting Embedded Signup. Our engineering teams are investigating the issue. We will provide another update within 1 hour or sooner if additional information is available.

Meta status: High disruptions
Source: https://metastatus.com/whatsapp-business-api
Posted Jun 12, 2026 - 16:12 UTC

Update

Update from Meta (Messenger Platform — Platform Status):

We are currently experiencing high disruptions impacting Messenger Platform. Our engineering teams are investigating the issue. We will provide another update if additional information is available.

Meta status: High disruptions
Source: https://metastatus.com/whatsapp-business-api
Posted Jun 12, 2026 - 14:51 UTC

Update

Meta has posted the following active service disruptions (source: https://metastatus.com/whatsapp-business-api):

• WhatsApp Business Platform — Cloud API (High disruptions)
We are currently experiencing high disruptions impacting WhatsApp Cloud API. Our engineering teams are investigating the issue. We will provide another update within 1 hour or sooner if additional information is available.

• WhatsApp Business Platform — Coexistence - Messaging (High disruptions)
We are currently experiencing high disruptions impacting WhatsApp Coexistence. Our engineering teams are investigating the issue. We will provide another update within 1 hour or sooner if additional information is available.

• WhatsApp Business Platform — Coexistence - Onboarding (High disruptions)
We are currently experiencing high disruptions impacting WhatsApp Coexistence. Our engineering teams are investigating the issue. We will provide another update within 1 hour or sooner if additional information is available.

• WhatsApp Business Platform — Marketing Messages API for WhatsApp (High disruptions)
We are currently experiencing high disruptions impacting Marketing Messages API for WhatsApp. Our engineering teams are investigating the issue. We will provide another update within 1 hour or sooner if additional information is available.

• WhatsApp Business Platform — Cloud API - Calling (High disruptions)
We are currently experiencing high disruptions impacting Cloud API - Calling. Our engineering teams are investigating the issue. We will provide another update within 1 hour or sooner if additional information is available.

• Messenger API for Instagram — Platform Status (High disruptions)
We are currently experiencing high disruptions impacting Messenger API for Instagram. Our engineering teams are investigating the issue. We will provide another update if additional information is available.
Posted Jun 12, 2026 - 14:46 UTC

Identified

Meta has acknowledged an issue affecting WhatsApp Business API and related messaging services. This is an upstream outage on Meta's side, not a Flow XO platform issue. You can follow Meta's status and updates here: https://metastatus.com/whatsapp-business-api

We continue to monitor and will update this incident as services recover.
Posted Jun 12, 2026 - 14:44 UTC

Investigating

We are monitoring and will provide more information as it becomes available.
Posted Jun 12, 2026 - 14:03 UTC