Major Outage
Incident Report for Flow XO
Resolved
This incident has been resolved
Posted Dec 13, 2024 - 16:48 UTC
Investigating
We are experiencing an outage, more detials to follow
Posted Dec 13, 2024 - 16:25 UTC
This incident affected: Application and Messaging Servers.