Major Outage

Incident Report for Flow XO

Resolved

"Monitoring - A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors"
Posted Nov 18, 2025 - 14:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 13:15 UTC

Update

Identified - The issue has been identified and a fix is being implemented.
Nov 18, 2025 - 13:09 UTC
Posted Nov 18, 2025 - 13:15 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:19 UTC

Investigating

Our host, Cloudflare, is currently experiencing a major outage and this is causing major downtime for our platform. We will monitor the situation and provide updates as we get them. You can also follow along here (https://www.cloudflarestatus.com/).
Posted Nov 18, 2025 - 12:19 UTC
This incident affected: Application, Messaging Servers, Web Chat Servers, Slack Servers, Facebook Messenger, and Public Website.