We are having a major outage - we are invesatigating
Incident Report for Flow XO
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 18:13 UTC
Monitoring
Service has returned to normal.
Posted Nov 08, 2023 - 15:56 UTC
Investigating
We are currently investigating this issue.
Posted Nov 08, 2023 - 15:50 UTC