Public Website Down
Incident Report for Flow XO
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 12:54 UTC
Update
Google has restored cooling to their data center, and are now working to restore services. There is no ETA provided, but presumably things are moving in the right direction now.
Posted Jul 19, 2022 - 23:20 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2022 - 21:21 UTC
Identified
This outage appears to be caused by ... climate change: https://www.bleepingcomputer.com/news/security/uk-heat-wave-causes-google-and-oracle-cloud-outages/

We will monitor the situation and if the outage continues, consider moving our public site hosting out of EU.
Posted Jul 19, 2022 - 21:20 UTC
Investigating
Our public website is suffering from an outage caused by our downstream service provider. You can follow along with their status page here: https://wpenginestatus.com/incidents/381158

Currently all chatbot services and the back office tools are functioning normally, and can be accessed directly at https://www.flowx.com/app
Posted Jul 19, 2022 - 21:15 UTC
This incident affected: Public Website.